Download

2018-08-17 (金) 17:24:15 (2d)





アプリケーション版の動作環境


対応OSMac OS X Mavericks 以降
Windows 7 以降*1
HDD空き容量10MB〜20MB
メモリ空き256MB以上推奨


対応状況


app/exeWeb Player
Safari/Chrome/Opera
Web Player
Firefox
ペンタブレットの筆圧
初期設定の記憶
ローカルへの保存と出力*2
ローカルファイルの読込
画像データの自動保存
Mac ⌘キーの使用△(※)


  • Web Player においては最新版の Adobe Flash Player が必要です。
  • http://pixelliner.sakura.ne.jp がコンピュータに情報を保存することを許可しますか?」のダイアログが表示された場合は、「はい」をクリックして下さい。(「いいえ」を選ぶと環境設定等が保存されません)
    • このダイアログは、右クリックでメニューを出し「設定」を選ぶと現れます。
  • Local Web Player は Web Player と同様の対応状況ですが、実行のために Flash のセキュリティ設定を編集する必要があります。(同梱の readme_SJIS.txt をご確認下さい。)
  • ※コマンドキーについて、Firefox以外の Web Player を使用した場合、アプリケーション側のキーボードショートカットと競合が起こった場合(⌘+Wなど)は多くの場合アプリケーション側が優先されます

リリースノート

180817 17:20 ver 0.95.4

  • 保存時に拡張子を自動で補完できるような設定を追加。
  • 非表示レイヤーに描画ツールを実行できないようにするオプションを追加。
  • ZIP 出力時に各レイヤーごとにトリミングできる機能を追加。
  • ポーズタブ上でキャラクター行をクリックしても編集キャラクターを変更することができなかった問題を修正。
  • ポーズタブ上で編集していないキャラクター行で右クリックして「閉じる」を実行した時、正しく閉じることができなかった問題を修正。
  • 新規に作成したキャラクターを閉じる際に、ダイアログ中で「保存する」を選んで保存ダイアログを出すとエラーが起こる問題を修正。
  • 指先ツールを目にも止まらぬ速さでクリックするとツールの終了時にエラーが起こる問題を修正。
  • パーツパレットのコピー/ペーストに対応。
  • ダイアログからパーツを削除した時にバグる問題を修正。
  • 何らかの理由で同じ色のパーツが存在してしまった場合に、パーツ削除や追加のヒストリが正しく実行できなくなっていた問題を修正。
  • パーツパレットの色をカラーコードによって設定する時にカラーコードが設定値からズレてしまう問題を修正。

180727 1:30 ver 0.95.3

  • PSD 出力時、描画モードが反映されるよう修正。
  • レイヤー変形ツールで作成したフロートレイヤーを、レイヤー移動ツールでAlt+ドラッグするとフロートで複製できない問題を修正。
  • GIF,APNG,AVIを出力した後、プログレスバーが進行中に出力予定のフレームを削除すると正しく出力できなくなる問題を修正。
  • 出力の際、レイヤーの一部が出力されない問題を(たぶん)修正。
  • カラータブ上でポップアップボタンからパーツを選択するメニューを出した時に、メニューの一部が重複する問題を(たぶん)修正。

180723 18:25 ver 0.95.2

  • 「下のレイヤーと統合」機能がうまく動作していなかった問題を修正。
  • UIの大きさを調整。また、ダイアログ内の文字色が設定タブで指定した文字色の色で表示されてしまい、ダークテーマだと見にくくなってしまう問題を修正。

180723 13:50 ver 0.95.1

  • 新規カンバスを作るときにサイズを指定するか特定値を設定するかするダイアログを出せる機能を追加。
  • 変形ツールで上下左右辺をつかんで変形するときに、反対辺の位置がイメージの辺とズレていた問題を修正。
  • 異なるキャラクターを開いて作業を始めた時に「イメージID XXX が見つかりません」という多数のエラーが出る問題を修正。
  • レイヤータブ上で目アイコンを Alt+クリック してレイヤーを個別表示している時に、変形ツールなどでフロートレイヤーを切り抜くと正しく描画が更新されない問題を修正。
  • 選択範囲を作ってレイヤーを編集しようとした時、プロンプトサムネイルのスクロールの初期位置がずれることがあった問題を修正。
  • アシストメニューから一度レイヤー境界などのアシスト表示アイテムを作成し、メニューをもう一度選択してチェックマークを外し、アシスト > 表示する を2回実行して全アシストの表示を切り替えると、非- 表示にしておいたはずの最初に作成した表示アイテムが再度表示されてしまう問題を修正。

180720 19:20 ver 0.95.0

  • スウォッチタブの追加。
  • レイヤー > 複数レイヤー処理... で新規レイヤーまたはペーストを行うとき、同じレイヤー名が存在する場合は処理を行わないオプションを追加。
  • 鉛筆ツールなどの描画ツールで描き込みを行う際にデフォルトの設定ではカンバス外には描き込みをしないよう修正(設定タブで変更できます。)

180718 21:30 ver 0.94.8

  • (AIR) 自動アップデートチェックを実装。
  • 特定のレイヤー名のレイヤーを選択したり、1枚のレイヤーを複数同時にペーストしたりする新機能 レイヤー > 複数レイヤー処理... の機能を追加。
  • zip で出力する際、レイヤーごとに出力できるオプション、および出力画像をトリミングするオプションを追加。
  • サイズの大きい画像でフロートレイヤーを複数枚作成したあとにフロートレイヤーを結合すると動作が遅くなる問題を修正。
  • フロートレイヤーを複数枚作成したあとにフロートレイヤーを結合したあと、取り消し操作で正しくアンドゥできない問題を修正。
  • 全てのポーズに対して色相/彩度などの色調の調整を行ってすぐに保存しファイルを閉じると、編集中の方向以外の画像が保存されない問題を修正。
  • フレーム間を移動したとき、直前に編集しいたレイヤーと同じ名前のレイヤーを自動的に選択する機能が動作していなかった問題を修正。

180529 1:29 ver 0.94.7

  • APNG での出力および入力に対応。

180528 20:20 ver 0.94.6

  • AVI での出力に対応。

180525 14:27 ver 0.94.5

  • インポートレイヤー上で選択範囲/レイヤー/フレームペーストを行うと、元のインポートレイヤーが消えてしまう問題を修正。
  • 前のフレーム/次のフレームでフレーム間を遷移したとき、移動前のレイヤー名のフロートレイヤーが存在するときはフロートレイヤーにフォーカスするよう修正。

180524 19:54 ver 0.94.4

  • 作ったばかりの空のレイヤーに対してレイヤー/選択範囲をペーストした場合、または空のレイヤー1枚のみが含まれたフレームにフレームをペーストした場合は、元にあった空レイヤーを削除するように修正。
  • スプレー/スタンプで個別アルファを100/100未満に設定していると描画がされなかった問題を修正。
  • GIF 出力時に「アルファを考慮しない」などのチェックボックスが出力ファイルに反映されていなかった問題を修正。
  • GIF 出力時に透過しきい値が 0 になっていると、透過部分が透明色と正しくブレンドされない問題を修正。
  • PNG, ZIP 出力時にも背景色および透過しきい値を設定できるよう修正。
  • 出力時に「アルファを考慮しない」チェックボックスを入れた場合でもマスク/クリッピング処理は行われるよう修正。
  • GIF, PNG, ZIP 出力時に拡大率が等倍でない場合にマスクレイヤーが機能していなかった問題を修正。

180523 20:16 ver 0.94.3

  • 描画色/背景色を選択する時に、HSV(色相/彩度/明度)から色を入力できるように修正。
  • 消しゴムツール使用時に「透明部分には描かない」「描画部分には描かない」をチェックしていても、無視して通常の消去処理を行えるオプションを追加。
  • カンバスの表示倍率をフィールドではなくスライダーで表示するよう変更。代わりに、拡大/縮小ツール上に現在の拡大率を数字で表示するようにフィールドを追加。
  • 最初にドキュメントを開いた時、また 表示 > 全て表示 を実行した時に、外枠ではなく内枠にフィットするように修正。
  • 内枠サイズが同じポーズに移動した場合にカンバスの拡大率を変更しないよう修正。
  • 選択 > 内側のみ選択 メニューを実行した時、なにも選択範囲がない場合は現在のレイヤーの内側 1px を選択するよう修正。

180523 0:32 ver 0.94.2

  • 空のレイヤーと描画内容があるレイヤーが1枚ずつ含まれたフレーム等のサムネイルをマウスオーバーで出そうとすると #1009 エラーが発生していた問題を修正。
  • 明るく/暗くツールを追加。指定色で乗算やスクリーンをかける機能のほか、パーツ内のパレットから隣り合った明るい色/暗い色に移動させる機能があります。
  • 選択>内側のみ選択 メニューを追加。
  • 矩形/楕円選択において、位置によっては矩形を作り始める位置が押したピクセルから微妙にズレていた問題を修正。
  • 直近ファイルの最大数が設定タブで指定した量より1少なかった問題を修正。

180520 14:10 ver 0.94.1

  • カンバス外の内容を切り取る 描画>カンバス外の描画内容を消去 を追加。
  • 描画モードがアルファのときにゴーストを表示しないよう修正。
  • 出力時、カンバス外に描画内容があると「自動」ボタンでの外接領域が膨らんでしまう問題を修正。
  • スタンプツールやスプレーツールで、素材が全て削除されているときでも処理を開始できてしまう問題を修正。
  • 素材ファイルを更新した時にスタンプツールやスプレーツールのサムネイルが即時に反映されなかった問題を修正。
  • スタンプ、スプレーツール編集画面で「素材ファイルを開く」をクリックしたときに、最後に追加したスタンプ素材のレイヤーにジャンプできるよう修正。
  • スタンプ、スプレーツール編集画面で「円形を削除」をクリックしたときに、複数の円形/矩形を選択しているときは全てを削除できるよう修正。

180518 20:17 ver 0.94

  • 新しくスタンプツールを実装。登録した素材を貼り付けることが可能に。
  • 塗り潰しツールでドラッグを行った際の動作で未実装だった閉領域フィル機能を実装。
  • パターンによる塗り潰しを行う際に、クリックしたグリッド内にのみ塗り潰しできるオプション追加。
  • 素材に新しくチップカテゴリを追加。パターンと同様に扱うことができますが、パターンとは異なりイメージに空白部分をもたせることができます。
  • アシスト>パターン敷き詰めメニューを追加。パターンを敷き詰めたときのシミュレートを行えるほか、一部ツールではそのままシミュレートされた部分に描画を行うことができます。
  • パターン、スプレー、スタンプでの素材の使用の際に、素材のイメージデータをどのように扱うかのポップアップを追加。とくに、「素材画像をそのまま貼り付ける」を選択することで、本来の描画色を完全に無視して素材の画像をそのまま現在のカンバスに呼び出せる機能を追加しました。
  • 鉛筆/消しゴムツール限定で補正機能を追加。カーソルの移動をある程度間引きし、直線的なストロークを描くことで Pixel Perfect な線に近付くよう調節できます。
  • 塗り潰しツールでパターンを使用して塗りつぶそうとした場合に、選択範囲など塗り潰し範囲の位置によってパターンの基点がズレてしまう問題を修正。
  • パターン/スプレー編集の作り直し。選択している素材イメージから該当の素材レイヤーにジャンプできるボタンを追加。また、素材セレクタフィールドの増設と、素材の名前を編集できるように修正。
  • ZIPファイルを出力するとき、カンバスサイズが異なる複数のポーズを選択して複数ポーズを同時に出力したときも、外枠/内枠/自動に合わせる設定が正しくそれぞれのポーズの外枠/内枠/自動にフィットするようになりました。
  • レイヤー変形ツールからShiftキーを押して回転を行った際、正確に90度や180度などの節目の角度に合わせることができず、わずかに画像がゆがむことがあった問題を修正。
  • GIF画像の出力の際、アニメーションのうちループする部分を複数回ファイルに記録できるオプションを追加。 F0 → 1 → 2 → 3 →1 → ... と、戻り先が F1 に指定されているアニメを出力する際に、いままでは F0 → 1 → 2 → 3 の4枚までしか出力できませんでしたが、 F0 → 1 → 2 → 3 → 1 → 2 → 3 というように繰り返し部分を複数回記録した (4+3xN) 枚のフレームの GIF 画像を出力できます。

180426 16:46 ver 0.93.3

  • レイヤー変形ツールに「縦横比を固定」ボタンを追加。
  • レイヤー変形ツールの上部フィールドに数値を入力して変形を実行した後、再度数値を入力しようとするとうまく変形できない問題を修正。
  • レイヤー変形ツール、および 描画 > 拡大/縮小/回転... メニューで、幅や高さが奇数のレイヤーの反転や回転が正しい位置から1pxずれていた問題を修正。それに伴い、 描画 > 拡大/縮小/回転... メニューでは「手入力」での基準値入力に小数値の入力に対応した。
  • アルファが100未満のレイヤーや非表示のレイヤーに対してレイヤー移動ツール等でフロートレイヤーで切り分けた後、フロートレイヤーを確定する際にアルファ情報が壊れていた問題を修正。

180426 16:46 ver 0.93.2

  • Shift+Altでナナメ方向にフィックスして鉛筆ツール等を動作させた時に、長距離を描こうとすると描画がズレる問題を修正。

180425 19:07 ver 0.93.1

  • 鉛筆ツール等でShiftを押して左右またはナナメにフィックスを行う際の方向がわかりやすくなるようにアシストを表示するように修正。
  • 初期設定の読み込み時にタブ位置がズレていた問題を修正。

180424 21:18 ver 0.93

  • UIの丸みを調整できるよう修正。
  • 出力時のデフォルト名称、およびzipファイルのディレクトリ名称を変更できるよう修正。
  • 「カンバス/選択範囲の内容をPNGで保存」での出力時の倍率を調整できるオプションを追加。
  • ヘルプを画面下部に出せるよう修正。
  • ヘルプを非表示にしていた際に、メニューのヘルプで該当部分のヘルプページにジャンプできない問題を修正。
  • 拡大/回転時に意図しないアンチエイリアスが発生する問題を修正。
  • インポートレイヤーをインポート元のラスターレイヤーに結合した時に正しく取り消しできない問題を修正。
  • レイヤーの描画範囲を選択した場合に外接矩形の正しいサイズが取得できていなかった問題を修正。
  • 保存および出力中にファイルをクローズできた問題を修正。
  • 保存および出力中にアプリケーションを終了しようとするとあらゆる操作を受け付けなくなってしまう問題を修正。
  • 新しいドキュメントを保存した時に直近のファイル群に記録されない問題を修正。
  • 出力した際に保存したファイルの名称が下部のアナウンスに反映されない問題を修正。
  • レイヤータブ上でAlt+クリックでレイヤーを個別に表示している際に、マジックワンドツールで「同じフレーム」を選択して実行しても見た目通りの選択効果が得られない問題を修正。
  • フロートレイヤーが生まれた際にツールタブに結合ボタンを表示するように修正。
  • フロートレイヤーを選択している時は、メニューの「インポートを確定」が「フロートレイヤーをラスタライズ」に名称が変わるよう修正。
  • 複数のサブカンバスに同じフレームを表示していた場合に、レイヤーのアルファ値などを変更しても描画が反映されなかった問題を修正。

180125 20:30 ver 0.92.12

  • 方向値を編集した際に正しくセーブされていない問題、およびそれに付随して出力時にハングアップすることがあった問題を修正。

180110 21:50 ver 0.92.11

  • 小さすぎるカンバスサイズを急激に大きくしようとした場合に、サムネイルサイズの見た目上のサイズが膨大になりハングアップする問題を修正。
  • 「ズームツール等のキーバインドを押し下げたまま使用した時は元のツールに戻す」がオンの時、該当するツールと同じキーの押上時にツール切り替えが暴発することがあった問題を修正。
  • ごく稀にヒストリーにロックがかかり新しく記録ができなくなる問題を微修正。(鉛筆ツールを使うと強制的にヒストリーロックを解除するのみで、根本的解決ではありません…)
  • レイヤーを上下に並べ替えるメニューを実装

170924 14:20 ver 0.92.10

  • ポーズジャンプ機能を実装。アニメの終了時に別のポーズに連結して表示することを想定している場合に、再生時にジャンプして表示することができます。
  • オプション拡充。ツール使用中のカンバススクロール、ペースト時にフロートレイヤーを作成するかどうかの設定、キーバインドを押し下げたままツールを使用した時に直前のツールに戻すかどうか、レイヤーパレットの目アイコンを Shift+クリック した際のアルファ設定値の変更。

170829 12:50 ver 0.92.9

  • レイヤーとフロートレイヤーを選択し手動レイヤー結合を行うとハングアップする問題を修正。

170823 13:08 ver 0.92.8

  • レイヤーを並べ替えたあと右クリックメニューからレイヤーの削除などを実行すると選択レイヤーではないレイヤーに処理が実行される問題を修正。
  • 「拡大と縮小...」メニューを「拡大/縮小/回転...」にリネーム。中央位置を指定しての回転(45°刻みも可能)に対応しました。
  • 「拡大/縮小/回転...」および「スクロール...」のプロンプトで、中央位置および適用範囲を描画するよう修正。
  • なにも描画されていないレイヤーにスクロールを実行すると、以降プロンプト上の「レイヤー」ラジオボタンが押せなくなる問題を修正。

170719 17:04 ver 0.92.7

  • 複数のレイヤーを選択して結合した場合に、基点となるレイヤーを上下どちらにするかのオプション項目を追加。

170719 15:22 ver 0.92.6

  • 変形ツールのツールパレット上フィールドから変形した場合にうまく動作しない/ヒストリに登録されなかったバグを修正。
  • 選択範囲の拡縮が動作しなかった問題を修正。
  • レイヤー統合処理で、不透明部分のうちパーツ未定義部がグレーにならないことがあった問題を修正。

170701 12:30 ver 0.92.5

  • GIF 出力時の再生速度が反映されない問題を修正。
  • 複数のレイヤーまたはフレームをコピー&ペーストする際に順番が壊れることがあった問題を修正。
  • アニメメニュー拡張。メニューからフレーム選択や入れ替えができるようにしました。
  • レイヤーメニュー拡張。同名のレイヤーを選択に取ることができるようになりました。

170608 17:50 ver 0.92.3

  • 指先ツールを使い続けるとメモリリークが発生し動作が重くなる問題を修正。
  • 出力設定情報をキャラクターに保存するよう修正。

170604 17:50 ver 0.92.2

  • メインカンバスのR (回転) フィールドが動作していなかった問題を修正

170603 12:50 ver 0.92.1

  • 消去コマンド使用直後鉛筆ツールで正しくパーツカラーが書けなかった問題を修正
  • 「エクスプローラ上に表示」メニューを追加

170602 12:10 ver 0.92

  • 修飾キーとの組み合わせでしか呼び出せなかったスポイトツールやカンバス回転ツールなどを単体で選べるようプリセットパネルに出しました
  • クイックマスクを安定化
  • (Air?) 入力フィールド外で IME が動作しないよう修正。
  • 方向とポーズ削除でエラーが発生した問題を修正
  • クイックマスク編集時にレイヤー変形ツールを用いると書き位置がズレる問題を修正
  • (Air) 新規に保存した際に直近ファイル履歴にファイルが送られていなかったので修正
  • 要素を10個以上コピーしていると新しくコピーできなかった問題を修正
  • フレームを複数枚ペーストした際に順番が壊れる問題を修正
  • ゴーストのみを表示している時にスポイトでパーツを取れない問題を修正

170526 12:10 ver 0.91.9

  • レイヤーの並び替えの際エラーが発生した問題を修正

170526 12:10 ver 0.91.8

  • (Air) 直近ファイルの入手順が逆転してロードされていた問題が直したつもりで直っていませんでした
  • スペースキーが押されている場合にスポイトツールでパーツが正しく取れなかった問題を修正
  • レイヤー変形ツールの動作が重かったので修正
  • レイヤー変形ツールで Shift キーを押した時に拡大率がおかしくなっていた問題を修正

170525 12:10 ver 0.91.7

  • 鉛筆ツール等描画ツールを用いた後、ゴースト切替の後にクイックマスクの表示がおかしい問題修正
  • レイヤーが複数枚存在するときに正しいパーツがとれない問題を修正
  • (Air) 直近ファイルの入手順が逆転してロードされていた問題を修正

170525 12:10 ver 0.91.6

  • ヘルプ表示の情報が設定に保存されていなかった問題を修正
  • パターンを「他のツールと設定を共有」で使っている場合に、ツールタブ上で黒白反転を押して反転を切り替えると、ツールの切替時に反転情報が破棄される問題を修正。
  • 選択範囲移動時、レイヤー移動ツール使用時の描画処理を若干高速化。
  • 塗り潰しプロンプト等のサムネイルで、ボタンからズームイン/アウトした時にかならずスクロールが真ん中に戻っていた問題を修正

170524 18:00 ver 0.91.5

  • ヘルプ表示の実装。
  • (0.91.3 -> 0.91.5) 描画のタイミングが不安定な問題の修正

170523 22:40 ver 0.91.2

  • Web 版で右クリックメニューが出なかった問題を修正。
  • Air 版は特に更新はありませんが、なぜか起動できなくなっていたかもしれないので差し替えています

170523 20:30 ver 0.91.1

  • スポイトでパーツ選択を省略するデフォルトの修飾キーを Ctrl に変更。
  • ロック表示機能を追加。現在のツールと、ツールの情報(透明部分ロックなどのロック情報)、選択範囲の有無、パターン使用の有無をカンバスの左上に表示します。
  • パターンを使用できるツールで、ツールタブにパターンの黒白反転ボタンを追加。(パターン編集ダイアログを開かずに白黒反転できます)
  • パターン描画処理を多少高速化。
  • 選択範囲で囲っている場合に塗り潰しプロンプト等を呼び出した場合、デフォルトでサムネイルを適用範囲周辺にズームアップするよう修正。

170522 15:30 ver 0.91

  • サブカンバスがどのフレームを表示しているかの更新タイミングが遅い問題修正。
  • インポートレイヤーに対してレイヤー情報編集を行った際に、レイヤーのインポート元を変更できる機能を追加。
  • スキンに「ネイチャー」「ダーク」追加。
  • 設定に「タブを小さく作る」「消しゴムツール使用時のスポイト処理」を追加。
  • 複数フレームを同時に編集する際に、名前無しに設定することができない問題を修正。

170520 14:20 ver 0.90.8

  • GIF を出力時、 Web で見ると再生時ループされない問題を修正。
  • GIF を出力時、全体で使っている色数が極端に少ないと色味がおかしくなる問題を修正。

170519 16:20 ver 0.90.7

  • スプレーツールで用いるカスタムブラシに通常円、通常矩形を追加/削除できるように修正。
  • ソフトブラシで速度を流量に反映する機能が動いていなかったバグを修正。

170518 17:18 ver 0.90.6

  • スプレーツールの追加。
  • ツールが使用するメモリの解放が杜撰だったので整理。

170517 17:53 ver 0.90.5

  • ソフトブラシツール、ソフト消しゴムツール、レイヤー選択ツールの追加。
  • パーツ色一括置換機能を追加。
  • パーツ用色相/彩度など、パーツに対してのカラー補正を実行した際に、インポートレイヤーに重複して効果がかかる問題を修正。
  • (ver 0.90.4 -> 0.90.5) パーツ色一括置換プロンプトが一定条件で実行できない問題を修正。

170516 1:26 ver 0.90.3

  • 新規フレーム (構造保持) を実行時にブレンドモードが反映されない問題修正。
  • レイヤー統合時にブレンドモードが反映されない問題、3枚以上のレイヤーの統合の前後で取り消しを行うとデータが壊れる問題を修正。
  • 選択範囲クロップで、選択範囲を用意していない場合はレイヤーの大きさを確保できる機能を追加。
  • 鏡面ツール使用時に表示がおかしい問題を修正。
  • カンバスサイズ変更時に内枠変更タイミングがおかしい問題を修正。
  • 全て表示 で1.0倍未満に縮小しなかった問題を修正。
  • (ゴースト表示機能と干渉する場合があったため)スポイトでパーツを無視する時に使う修飾キーをキーコンフィグで変更できるよう修正。

170514 23:42 ver 0.90.2

  • マイナーチェンジ。(0.90.1 -> 0.90.2) Win版で起動できなかった問題を修正。
  • マイナーチェンジ。 Win版でメニュー上からの保存が動作しなかった問題を修正。

170514 15:10 ver 0.90

  • マイナーチェンジ。 Web Player でタブドラッグ時にエラーが出た問題を修正。保存ができなかった問題を修正。

170514 2:30 ver 0.90

  • ローカルアプリ版公開
  • キーボードショートカットGUI実装、鏡面ツール追加、トーンカーブや色相/彩度フィルタの追加。
  • パターンとマテリアル管理の実装。
  • 「アニメ」タブの強化。アニメタブ上で選択やフレーム移動が可能に。
  • ファイルのドラッグアンドドロップに対応
  • フロートレイヤー確定の前後で取り消しを行うとパーツチャンネルが破壊された問題を修正
  • 別のフレームにあるフロートレイヤーが確定されるような操作(選択範囲解除など)を行うと、フロートが存在していたフレームに引き戻される問題を修正
  • レイヤーをコピーできなかった問題を修正
  • 内容が不正なファイルを読ませた時のエラーハンドリングの向上
  • インポートされた元のラスターレイヤーの回転を行うとインポート側のレイヤーとのリンクが切れる問題を修正
  • 選択範囲がある場合に塗り潰しツールを使うとうまく描画できない問題を修正
  • レイヤーバッファ外に選択範囲を作ってフチ取りおよび塗り潰しツールを実行すると描画されない問題を修正
  • 他、もろもろのバグ修正と、動作速度の向上

170226 17:21 ... ver 0.55

  • グラデーションツール追加
  • 描画メニューにいらん項目があったので消去
  • 複数枚のフロートレイヤーを重ねて結合した際に正しくヒストリが記録されない問題を修正
  • フロートレイヤーが含まれるフレームの増減を取り消しした場合にエラーが発生する問題を修正
  • パーツチャンネル上のアルファが100%未満の部分をパーツモード時に取得できなかった問題を修正

170225 19:21 ... ver 0.54

  • 選択範囲が存在しないときに消去コマンドをオフにできる機能のバグ修正
  • キャッシュから自動読み込みしたイメージを新規ポーズに配置した直後に保存するとイメージが保存されなくなっていた問題を修正
  • ローカル保存領域の容量が0のときに設定等を保存しようとした際にエラー落ちする問題を修正
  • フレーム作成後に取り消しを行うとエラーが発生する問題を修正
  • サブカンバスに対して選択範囲を作ったレイヤー移動を行うとただしくフロートレイヤーが選択されない問題を修正

170225 17:24 ... ver 0.53

  • サブカンバスを作っていると起動できない問題を修正
  • カンバスナビゲーションバーの非表示に対応
  • タブ間のスプリッターを移動した時にドラッグがリリースされない問題修正

170225 11:27 ... ver 0.52

  • 選択範囲が存在しないときに消去コマンドをオフにできる設定を追加
  • Mac/Win式のショートカット表示に対応
  • 取り消し時にエラーが発生する問題を修正。
  • タブの色変更に対応

170224 21:00 ... ver 0.51

  • いくつかバグフィックス。

170224 17時頃 ... ver 0.50

  • ひっそり公開

*1 XP でも動くらしいです。
*2 app/exeにおいては一般的なアプリケーションと同等の保存機能を実装しています。Web版においては必ず別名で保存を行わなければローカルへの出力はできない代わりに、キャッシュセーブと画像データ自動保存機能を実装しています。